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1 About GravityDrift

The GravityDrift program is designed to calculate a zero-drift for SCINTREX CG–5 gravime-
ter.

1.1 Program editions

The GravityDrift 1.4 is available in the following editions:

• Demo — is designed to review the program’s possibilities;

• Standard — is recommended in case if the program is used only for express calculations
of gravimeter zero-drift;

• Professional — allows to use the program for viewing raw data and calculating additional
parameters;

• Expert — is designed for internal use in Deproil LTD company.

Table 1: Functionality of different GravityDrift program editions

Demo Standard Professional Expert

The ability to load data from the binary data
file Scintrex — Scintrex Geophysical Data

Format (*.SGD)
The ability to load raw data from the binary

data file Scintrex — Scintrex Geophysical
Data Format (*.SGD)

The ability to load data from the text version
of dump (*.TXT)

The ability to load data from the text version
of dump without headers (*.XYZ)

The ability to load data from the common
text file (*.DAT)

The ability to copy data from the
spreadsheets into the clipboard

The ability to copy non-processed data from
the spreadsheet of clipboard

Current version of the program can be checked in the main menu header and in the dialog
window “About”.

2



1.2 Program activation

To work with program GravityDrift v.1.4 you need a USB token and activation file Gravity-
Drift.key. The program works only if the USB token is plugged in. To activate the program go
to the main menu “Help → Program Activation”, select activation file and afterwards restart
the program.

1.3 Main menu

Program’s main menu contains:

• “File” — is used to perform operations with files, including data loading and saving files:

– “Open” — opens data files;

– “Recent files” — opens recently used files;
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– “Save” — saves the results of data analysis in text format;

– “Save Image...” — saves the image of program’s display space as a bitmap;

– “Print Image...” — sends the image of program’s display space to print;

– “Create report” — creates the report for the opened data file and saves it as *.pdf
file;

– “Close” — closes the current opened file;

– “Exit” — finishes program’s work.

• “Edit” — is used to work with data processing results:

– “Copy Image to Clipboard” — copies the image of display space into the Windows
data clipboard;

– “Copy Data to Clipboard” — copies data spreadsheet into the clipboard so it can be
inserted into Microsoft Excel;

– “Copy Results to Clipboard” — copies resulting data into the clipboard.
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• “Scale” — is used to set zooming for plot panel.

• “Options” — is used to set interface parameters and data visualization parameters:

– “Increase lines weight” — increases the width of red and black lines on the plot;

– “Decrease lines weight” – decreases the width of red and black lines on the plot;

– “Increase points size” — increases the size of points of the red and black lines on the
plot;

– “Decrease points size” — decreases the size of points of the red and black lines on
the plot;

– “Language select” — sets chosen language for the interface;
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– “Options” — sets additional program’s settings.

• “View” — is used to set location of plots and data spreadsheets:

– “Windows size default” — sets standard location of windows;

– “Align graphics and sheets” — sets the same vertical size for all plots and spread-
sheets;

– “Align graphics” — sets the same vertical size for all plots;

– “Show all” — displays all available plots;

– “Show gravity” — displays available plots with gravity field only.

• “Help” — contains information about current version of the program and manual on
program usage:

– “Help” — provides program description;

– “Program Activation” — provides instruction on program activation with the key
file;

– “About” — provides general information about the program.
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1.4 Toolbar

Toolbar contains the following functioning buttons: (left to right): “Open”, “Save”, “Save
Image”, “Print Image”, “Create report”, “Arbitrary windows”, “Decrease lines weight”, “In-
crease lines weight”, “Decrease points size”, “Increase points size”, “Help”.
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1.5 Plot panel

Plot panel is used to show graphical information concerning zero-drift calculation.

1.6 Setting panel

Setting panel is used to specify parameters of data analysis.

8



1.7 Histogram

Histogram shows parameters of random noise.

1.8 Results panel

Results panel shows the results of data analysis.
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1.9 Additional parameters panel

Panel of additional parameters shows additional plots if there are some.

Additional parameters are gravimeter temperature, standard deviation, inclination along
axis Ox and Oy, solar and lunar inequality, number of rejected points. All plots are shown in
units of the gravimeter internal format.

There is an option of checking statistics (mean value Mx and standard deviation Dx) for
each parameter. Statistical parameters are calculated using the following equations:

Mx =
1

N − 1

N∑
i=1

xi, Dx =

√√√√ 1

N − 1

N∑
i=1

(xi −Mx)2.

Mx and Dx units match the corresponding measurement units.
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Mean line is being plotted for each additional parameter.

1.10 Raw data visualization panel

In case when binary SGD file contains recorded raw data, it can be loaded into GravityDrift.
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1.11 Report

The report is designed to display information from the headers of analyzed data.

1.12 Spreadsheets

Spreadsheets contain loaded data.
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1.13 Status bar

Status bar displays number of loaded data points, which are being analyzed; time, marked
by the current position of the cursor over the plot panel (in absolute units and relatively to the
measurements start time); the value of measured gravity at that point or values of any other
parameter; relative cursor position.

1.14 Tooltips

Tooltips appear when to point the cursor at a function button.
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1.15 Shortcuts

Shortcuts are used to expedite common operations by

Key combination Operation
Ctrl + O Open data file
Ctrl + S Save file with analyzed data
Ctrl + X Close data file
Ctrl + J Open the window of program parameters
Ctrl + C Copy analysis results into the clipboard

F1 Open Help
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2 Program installing

To install the program user account must have Administrator privileges. To install the
program double click on gravitydrift 1.4.1.xxxx setup.exe (xxxx — build number).

In case when HASP key driver is already installed in your computer, checkbox will be
deselected, otherwise it will be selected as required to install.
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3 Startup

To start the program use one of the following methods:

• Go to the menu “Start”: “Start → Programs → GravityDrift 1.4 → Gravity Drift 1.4”.

• Go to shortcut “Gravity Drift 1.4” on your desktop or taskbar in case if corresponding
checkbox was selected while program installing.

• Double click with left mouse button on GravityDrift.exe file in the folder which contains
the installed program.

The main window will be opened after the program is started.

You can check current version of the program in the title bar or by selecting menu item
“Help → About”.
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4 Input data

Input data for Gravity Drift 1.4 is data observed by SCINTREX CG-5 gravimeter by means
of SCTUTIL program using standard port RS-232C or high-speed USB.

Currently, the following data format are available: text format (txt) — headers and ASCII
data, binary format (sgd), common file format (dat) — to import data not using SCTUTIL
program, text format with no header (xyz) — spreadsheets with data only.

In the program folder there is folder “Samples” which contains examples of different data
files. Corresponding shortcut can be found in the menu “Start → Programs → Gravity-
Drift 1.4 → Data samples”.

4.1 Headers and ASCII data (TXT)

Data in text format (text version of dump file) are text files ASCII with headers. Such files
can be opened by any text editor such as Notepad.

The option to load data in text format TXT is available in Expert version of the program.
To load text data use one of the following methods:

• Go to the main menu and select “File → Open”;

• Press button “Open” on the toolbar;

• Drag the file onto the opened window with mouse;

• Use shortcut Ctrl+O;

• Select file from the list “File → Recent files”.
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If to open text file using one of two first methods, you need to select file format (TXT) in
the drop down list, select file name from the list and press “Open”.
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If data file contains more than one survey or more than one survey line, than the optional
window for choosing survey/survey line will open.

Name for each group of data in the drop down list consists of survey starting date, measure-
ments starting and finish time, number of points along the survey line and name of survey line
in the file.

If grouping wasn’t based on data file header but instead by taking the maximum time
interval between measurements within the group, than the name of each sub-group will contain
it’s number ###[sub-group_number].
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Click “OK” when measurement group is selected. Loaded data will appear in the main
window.

4.2 Spreadsheets for ASCII data (XYZ)

Text file without headers (text version of dump file) contains the same information as ordi-
nary text files; the only difference is that there are no headers.

The option to load data in text format XYZ is available in Expert version of the program.
To load text data use one of the following methods:

• Go to the main menu and select “File → Open”;

• Press button “Open” on the toolbar;

• Drag the file onto the opened window with mouse;

• Use shortcut Ctrl+O;

• Select file from the list “File → Recent files”.
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If to open text file using one of two first methods, you need to select file format (XYZ) in
the drop down list, select file name from the list and press “Open”.
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When to download data in XYZ format a download selection window will appear (red line
on the picture denotes the range of data points).

Absence of headers makes it necessary to select a range of downloaded data manually. In
order to facilitate this operation there are plots of main data columns shown in the download
window. These plots change rapidly if to move from one data group to another. Corresponding
parameter are displayed as a spreadsheet in the left part of the download window.
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The right part of download window shows the plot for selected parameter.
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Since you can’t see the current value of zero-drift while loading data in XYZ format, you
need to enter its value manually into the corresponding table space.

Data will be loaded after you press “OK”.
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4.3 Binary data (SGD)

Binary data format, as long as text data format, is used to save the same data from gravime-
ter but in binary form which expedites downloading operation. In addition, it may contain raw
data for each measurement.

To load text data use one of the following methods:

• Go to the main menu and select “File → Open”;

• Press button “Open” on the toolbar;

• Drag the file onto the opened window with mouse;

• Use shortcut Ctrl+O;

• Select file from the list “File → Recent files”.
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If to open file using one of two first methods, you need to select file format (SGD) in the
drop down list, select file name from the list and press “Open”.
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If data file contains more than one survey or more than one survey line, than the optional
window for choosing survey/survey line will open.

When survey and survey line are selected press “OK”. Loaded data will be displayed in the
main window.
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If you use Professional edition of the program and there are raw data in the data file, a
message “Raw data detected” will appear in the status bar of the loading window. Also a
checkbox “Load raw data” will appear.

4.4 Simplified data format (DAT)

Simplified data format provides loading and analyzing data which were not observed by
SCINTREX CG–5 gravimeters.

To load text data use one of the following methods:

• Go to the main menu and select “File → Open”;

• Press button “Open” on the toolbar;

• Drag the file onto the opened window with mouse;

• Use shortcut Ctrl+O;

• Select file from the list “File → Recent files”.
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If to open file using one of two first methods, you need to select file format (DAT) in the
drop down list, select file name from the list and press “Open”.
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Simplified data format is structured as follows:

0.482

2010/01/22 19:14:16 5191.204

2010/01/22 19:15:23 5191.205

2010/01/22 19:16:28 5191.206

2010/01/22 19:17:33 5191.204

...

First row specifies the current zero-drift value, next rows contain data (data, time and gravity
correspondingly).
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5 Data visualization

Downloaded and analyzed data are shown on plot panel.

Any zone of display area on the plot panel can be zoomed by selecting it with a mouse. Red
line shows motion path of mouse cursor if to hold left mouse button.
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To return to the previous display area use corresponding control key.

Other control keys allow moving the display area.
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The panel shows:

• Black color marks the plot of input data observed by gravimeter.

• Red color marks the plot after zero-drift calculation.

• Green color marks input data trend. After the processing data are being calculated by
subtracting trend line.

• Gray color marks the line of data mean value within the analyzed interval.

• Blue color marks two restrictive lines which denote start and end of time interval of
analyzed data.

• Yellow color marks the cursor.

To change the position of restrictive lines (and starting / finish time interval correspondingly)
do one of the following:

• Choose “Interval start” in the right part of the window and double click with left mouse
button on the required plot area. Blue line which corresponds to the interval start will be
replaced into required position. Choose “Interval end” and double click with left mouse
button. Line of the interval end will be replaced.
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• Click with right mouse button on the required plot area. In the context menu choose
which one of three lines for the start/end of the interval should be replaced into selected
point.
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When the interval is selected you can control the time which is displayed in status bar.
When the analyzed interval is selected all calculations will be performed only

for the data inside of its interval.
The start and end of the interval should be selected basing on the requirement that data

must have a linear trend. Linear interval may be preceded (as in the previous example) by
stabilization interval. Start of the analysis interval must be selected after the completion of
stabilization interval.

Line width and point size on the red and black plots are variable parameters. To change
it go to the main menu (“Increase line width”, “Decrease the line width”, “Increase the point
size”, “Decrease the point size”), plot context menu (which is being activated by clicking right
mouse button on any point of the plot panel), and click corresponding buttons on the toolbar.
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Apart from gravity field plot you can also show other additional plots.
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Cursor will appear if to click with mouse on the workspace of any plot or select a cell on the
spreadsheet. It will denote the current position of selected point.
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6 Raw data viewing

Viewing and processing raw data is available if you use Professional and Expert program
edition.

Raw data can be loaded from files in Scintrex Geophysical Data Format (*.SGD).
If raw data have been detected in file while data loading, special notification will appear in

status bar of loading window. Checkbox “Load raw data” also becomes available.

All abscissa axes on the panel of row data are in seconds.
Data which are displayed on the row data panel depend on selected point. Cursor location

indicates the current point. Independent cursor is used for row data. This cursor is fixed to
spreadsheet “Raw data”.

Raw data are digitized with 6 Hz frequency and composed with four columns. The meanings
of these data: GravSample (gravity), TiltXSample (inclination of Ox), TiltYSample (inclination
of Oy) TempSample (temperature) can be found in *.smp files.

Gravity is calculated from raw data (GravSample) with the following the equation:

Gravity = GCAL1 ·
GravSample

536870912
,
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536870912 — is hexadecimal value 2000000016 — total size axis, GCAL1 — main calibration
constant.

Inclination of axes OX and OY can be calculated by the following equations:

TiltX =
(
(TiltXSample− TiltXOffset) · 0.000076295− 2.5

)
· TiltXSensitivity,

TiltY = −
((

(TiltYSample− TiltYOffset) · 0.000076295− 2.5
)
· TiltYSensitivity

)
,

TiltXOffset, TiltXSensitivity, TiltYOffset, TiltYSensitivity — gravimeter constants. Tempera-
ture is calculated by:

Temperature = (TempSample · TempSF)− TBIAS− TEOFF,

TBIAS = 500 , TempSF = 1000/536870912. TEOFF parameter is unique for each gravimeter
and its value in the calculation program is TEOFF = 0.

Changing location of the cursor in the data spreadsheet (also by using arrow buttons on the
keyboard) leads to moving current position of corresponding cursor.

The following plots are available for row data: gravity variations plot (mGal), temperature
variations plot (mK), Ox and Oy axis deviation plots (arcsec), gravimeter slope correction
(mGal), statistics on the current row data. Each value of displayed statistics can be copied into
the clipboard by using context menu in corresponding cell.
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Mean x, standard deviation σ and mean error SDOM for x parameter are calculated using
following equations:

x =
1

N − 1

N∑
i=1

xi, σ =

√√√√ 1

N − 1

N∑
i=1

(xi − x)2, SDOM =
σ√
N
.

You can also check the amplitude spectrum for row data. Axis Ox is frequency (Hz).

New plots and spreadsheets appear the row data view mode. New spreadsheet with row
data will be added.
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Three new plots will be added: confidence level plot, Ox and Oy axial deviation.

Additional columns appear in the main spreadsheet:
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All described parameters are being recalculated and redisplayed if it is necessary. Irrelevant
data in the spreadsheet will be replaced by sign “?” while calculations.
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7 View windows

A relative location of different panels can be changed using corresponding delimiters. All
possible delimiters are shown in figure with red line. Vertical delimiter is not active in case if
non-processed data are not being loaded.

Dragging delimiters leads to changing windows size.

By using the main menu command “View → Align” plots on the plot panel will be aligned
to the same size. Using the command “View → Align graphics and tables” you can align plots
and spreadsheets by the size.
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Command “View → Show field” is used to display only the plot (plots) of gravity field.

Command “View → Show all” is used to all available plots.
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Command “Arbitrary windows” on the toolbar is used to fix the alignment of plots in case
of changing the main program window size.
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8 Data filtration

Data filtration is used to reject high-amplitude artefacts. To switch on the data filtration
option activate the checkbox “Remove random noise” on the Settings panel and select amplitude
coefficient in the drop-down menu or by means of buttons “Up” and “Down”.

Coefficient α defines the amplitude limits, above which data rejection occurs. The point
(xi, yi) in the input data is being rejected if |yi−kxi− b| > ασ (k, b — linear trend coefficients).
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9 Histogram

Histogram shows the distribution of random noise which had been received after the removal
of high-amplitude artefacts and linear trend from input data.

Histogram plot shows:

• Histogram itself with the optimal number of columns;

• Gaussian function;

• Mean value (Mx);

• Dispersion (Dx);

• Parameter calculated by the formula
xmax − xmin

Dx
, and is used to evaluate a data uniformity

(Re);

• Parameter χ2;

• Confidence level Ur (percentages).

To configure the histogram go to program settings.
To see the data statistics go to context menu.
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10 Data analysis results

Data analysis results are shown in Results panel.

Analysis results can be copied into the clipboard Windows by key board combination Ctrl+C.
You can also export processed data using the main menu “File→ Save” or the corresponding

button on the toolbar. Data can be exported in formats txt (delimiters —space) and csv
(delimiter — semicolon). File format for saving can be selected in the corresponding file selection
window. Dataset in csv file format can be opened by Microsoft Excel with the default settings.
The following data columns are saved: date (date), time (time), decimal time (dec.time) and
gravity field (gravity).

It is also possible to capture the fragment of the screen, which includes plot bar, toolbar,
histogram and results panel. It can be saved it as png, bmp, jpg or gif files. To do it go to the
context menu and select “Save Image”.

You can create a pdf report on the data processing results. To create a report you should
select “File → Create report” in the main menu or press the corresponding button on the
toolbar.
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11 Program parameters

All parameters are saved in the configuration file GravityDrift.ini, which is stored in the
program folder.

53



54



55



12 Uninstalling

To uninstall the program follow one of two directions below:

• Go to the menu “Start → Programs → GravityDrift 1.4 x.x.x.x → Uninstall”.

• Go to the Control Panel and double click on Add/Remove Programs (in case if Register
Entries was activated whine installing the program).

• Run uninstall.exe in the program folder.
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13 Demo version

The demo version of the program has been established to demonstrate program’s possibilities.
It doesn’t support the mechanism of data import. If to try to open any file, the predefined
dataset will be loaded. You can select any file *.sgd in the folder with text data.
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